Vejledninger /

Installering

/

Krav

Krav

Piwigo kræver webhosting for at fungere. For en fotogalleriløsning med alt hvad der følger med (installering, hosting, sikkerhedskopier), eller hvis du blot ønsker at prøve Piwigo uden at installere, kan du overveje at åbne en gratis prøvekonto på Piwigo.com.

Minimumskrav

  • En webserver som Nginx eller Apache
  • MySQL 5 (eller tilsvarende med MariaDB)
  • PHP 5.3 (7.0 eller 7.1 anbefales)
  • Et grafisk bibliotek: ImageMagick anbefales pga. dets ydeevne og billedkvalitet, men GD, som ofte installeres med PHP, klarer det også.
  • et FTP-klientprogram er krævet for at overføre filerne (netinstall eller komplet pakke): Piwigo-holdet anbefaler FileZilla som FTP-klientprogram, fordi det som Piwigo er frit tilgængeligt, og er kompatibelt med Windows, Mac og Linux.
  • Tilstrækkelig diskplads til dine billeder: ud over de billeder, du overfører, gemmer Piwigo også forskellige størrelser i din servers cachemappe.

Valgfrie krav

  • exiftool kræves af plugin'en Write Metadata og enhver anden plugin, som håndterer EXIF-/IPTC-metadata
  • ffmpeg er krævet af plugin'en VideoJS for at oprette videoplakaten
  • pdftoppm anbefales for at generere en plakat fra PDF-filer (i stedet for ImageMagick)

Har du stadig ubesvarede spørgsmål?

Du kan få hjælp i vores forum eller finde dine egne svar i dokumentationen